Linux – ein Boot tut gut – ein Kaltstart ist besser

Mein Arbeitskollege hat sich einen neuen HTPC zusammengestellt: ASUS AT5IONT-I Deluxe (Intel Atom D525, NVIDIA GT 210 für VDPAU), Crucial m4 128GB und eine TeVii S470 TV-Karte für HD-Fernsehen (Sat), als Betriebssystem verwendet er Arch Linux mit Openbox.

Zum Abspielen der TV-Programme nutzte er bisher immer Kaffeine, so auch die erste Zeit mit dem neuen Media-PC. Nachdem ich ihm XBMC (PVR) mit dem HTS Tvheadend empfohlen habe, musste es ja so kommen, wie es kam.

Meine Telefon klingelt! Es werden keine TV-Sender mehr angezeigt, ein Sendersuchlauf im Kaffeine bricht nach 2-3 Sekunden ab.

Er hat XBMC (PVR) und das HTS Tvheadend installiert, danach gleich geschaut, ob Kaffeine theoretisch noch funktionieren würde, ja es funktionierte noch. Neustart! Jetzt werden im Webinterface vom Tvheadend (http://localhost:9981/) keine Sender gefunden, auch Kaffeine zeigt keine Sender mehr an – auch nach einem /etc/init.d/tvheadend stop nicht!

Erstmal haben wir das XBMC und Tvheadend deinstalliert, neugestartet, wieder können keine Sender im Kaffeine angezeigt werden, auch ein erneuter Sendersuchlauf brach gleich nach 2-3 Sekunden ohne Fehlermeldung ab. Ein w_scan auf der Bash brachte uns auch nicht weiter, …

… es werden einfach keine Sender gefunden. Unklar!

Kurze Zeit später ist mir in der /var/log/messages aufgefallen, dass die TV-Karte weder nach einer Firmware fragt noch eine Firmware lädt. Bekanntlich brauchen speziell WiFi- und TV-Karten fast immer ein passendes Firmware-File in /lib/firmware/.

In dieser Sache hatten wir mittlerweile Routine, ein …

… kopiert die passende Firmware (dvb-fe-ds3000.fw) für die TeVii S470 (Montage Technology DS3000/TS2020) nach /lib/firmware/. Neustart!

Wieder werden keine Satellitensender gefunden und keine Firmware-Anfragen in der System-Log angezeigt – ich war nach fast 2 Stunden mit meinen Latein am Ende und wollte gerade resignieren!

Nein, am Sattelitenkabel lag es nicht, das war eingesteckt! 😉

Das war’s – keine Idee mehr! Naja einen Kaltstart machen wir noch …

… 5-10 Sekunden gewartet, wieder eingeschaltet. Huh, er findet Sender, es werden wieder Sender angezeigt! Unglaublich, das war ja einfach^^!

Wo das Problem war, kann ich nur spekulieren, denn wir konnten das Problem nicht mehr nachstellen! Vielleicht hat sich die TV-Karte beim Laden der Firmware verschluckt und ist hängen geblieben, denn erst wenn die TV-Karte kurze Zeit stromlos ist, verliert die TV-Karte die Firmware wieder?! Wer weiß …?!

Jedenfalls war das mal wieder ein typischer Tag nach dem Motto – man lernt nie aus! Ein typisches Sprichwort in der IT: „Jeder Boot tut gut“ hat sich für mich, für alle Zeit verändert:

Ein Boot tut gut – ein Kaltstart ist besser!

PS: Seit fast 1 1/2 Monaten läuft bei meinem Arbeitskollegen nun XBMC (PVR) mit dem HTS Tvheadend. 😮

Veröffentlicht von

_nico

Mac-User aus Leidenschaft, Blogger seit Oktober 2009, 88er Baujahr, technikaffin. Ich fühle mich aber nicht nur auf Apple'schen Betriebssystemen zu Hause, alles was eine Shell hat, interessiert mich besonders! Ihr findet mich auch auf Twitter und Google+.

20 Gedanken zu „Linux – ein Boot tut gut – ein Kaltstart ist besser“

  1. moin…
    solche „hänger“ mit sat-karten kenne ich, allerdings aus der windows-welt. meine erste skystar 2 neigte dazu, sich nicht richtig abzuschalten, sprich das lnb wurde von der skystart 2 nicht richtig angesteuert. schließlich liegt ja da strom an und die steuerspannung wurde nicht unterbrochen. interessanter weise traten diese fehler mit linux-distributionen nicht auf. leider funktioniert keine skystar 2 (oder auch hd 2) mit mac os lion…

  2. Kenne das gleiche Problem bei anderen TV-Karten (einmal ProfTuners und die andere fällt mir gerade nicht ein) auch. Im Zweifel Rechner Auschalten, Kaffeepause machen, Anschalten und den Rest der Sendung sehen, die man umbedingt ganz sehen wollte :-).

  3. *Hust*
    OpenElec wäre für „Ich hab keine Ahnung und will nur Nutzen“ User wohl besser 😉 Da sind solche Probleme schon „behoben“.

    1. Hi Namerp,
      ich kam zu diesem Zeitpunkt, vorm Raspberry Pi, noch nicht mit OpenELEC in Berührung – daher war OpenELEC zu diesem Zeitpunkt noch keine Alternative.

      Wie ist das bei OpenELEC?

      – bei OpenELEC 1.0 oder 2.0 kann man als Addon „HTS Tvheadend“ installieren und TV dann als Quelle „htsp://localhost:9982“ hinzufügen oder? Man hat dann aber kein EPG, Videotext oder ähnliches, sondern nur den Stream?

      – bei OpenELEC PVR 2.0 hat man dann noch zusätzlich im Menü „Live TV“ (wie beim XBMC PVR-Testing), somit EPG, Videotext etc., oder? Ist beim PVR-Release bereits das „HTS Tvheadend“ installiert?

      Gruß Nico

      PS: > … „Ich hab keine Ahnung und will nur Nutzen“ User … < dies trifft so nicht zu! 😐

      1. Die OE 1.0 ist asbach alt und sollte nicht mehr benutzt werden.

        OE 2.0 (beta die eigentlich ganz gut funktionierend) ist im Prinzip ein ganz schmales Linux wo XBMC darauf läuft. Die TV Funktion funktioniert ordentlich (Timeshift funktioniert noch nicht), Kanalsortieren etc muss man via Webbrowser da TVHeadend das nicht intern kann (aber eigentlich angenehm). Alternativ kann man auch VDR benutzen. Epg klappt, sonst geht auch alles Problemlos (wenn auch nicht ganz bugfrei – die 1-2 Abstürze des TV´s aller jubel Tage kann man verschmerzen). Das TV Programm ist wie man es erwartet von der Bedienung.
        Bedienung allgemein ist Kinderleicht (Kanalsuche von TVH bisschen komisch aber per Tutorial problemlos).

        Auf PC (Intel,AMD,Ion …) geh das super, Raspberry wird seit neuestem auch unterstützt in wie weit da PVR läuft weiß ich nicht so recht mangels Raspberry. Installation ist kinderleicht (Zeitaufwand ~5min).

        Für einen normalen PC als Hardware die ganz normale passende OE 2.0 Beta 4 (oder je nach dem was neuer ist) nehmen. Für Raspberry hier die neuste Version laden ist noch in Entwicklung da käme es auf einen Versuch drauf an 🙂 (ARM Treiber für die DVB Karten ???)

        Treiber / Software musst du nichts nachinstallieren oder Konfigurieren alles klappt direkt (allermeistens). Nur die Einstellungen die du in XBMC so oder so machen musst sind nötig.

        Man benötigt keinerlei Linux Kenntnisse ! Per USB Stick Maker einen Installationsstick erstellen und los geht es (bei der Installation wird die gesamte Festplatte gelöscht!!!).

          1. OE 2.0 Beta 4 ist ohne PVR (DVB TV)
            OE 2.0 Beta 4 PVR ist mit PVR (DVB TV)

            Wenn man TV Unterstützung möchte sollte man auch die entsprechende PVR Version nehmen 🙂 (beim Raspberry weiß ich es nicht genau wie da die Unterstützung ist, deswegen einfach mal testen).

          2. @Namerp

            Also hast du über die PVR Version geschrieben.

            Das ist mir schon klar. Ich wollte nur wissen, ob das, was du erklärt hast die PVR Version war oder nicht. Weil man ja auch bei der non PVR Version das HTS Tvheadend über die Addon’s von XBMC nachinstallieren kann.

            @all

            Also kann man mit der non PVR Version zwar den Stream (wenn man das HTS Tvheadend nachinstalliert hat [htsp://localhost:9982]) empfangen, aber man hat keine EPG-Daten und keinen Videotext.

            Mit der PVR Version hat man, wie bei XBMC PVR, im Menü “Live TV”. Dort werden dann die EPG-Daten angezeigt, beim Schauen eines Senders kann über eine eingestellte Teletext-Taste auch der Videotext angezeigt werden.

            Gruß

  4. Das Problem habe ich auch bei meiner Tevii S464 und tritt soweit ich weiß immer auf, wenn ich in den Energiespar/Bereitschaftsmodus schalte (kanns grade nicht testen, weil der PC sich nach dem Energisparmodus aus unbekannten Gründen aufhängt..). Woran das liegt kann ich aber auch nicht sagen :/

    1. Ja, das Kenne ich auch von meiner S464. Mal geht sie, mal geht sie nicht. Nach dem Standbymodus geht sie grundsätzlich nicht. Ein nerviges Problem, es scheint als ob sich der Treiber schon bei der Karte meldet während diese noch die Firmware empfängt – woraufhin sich die Karte vollständig aufhängt.

  5. Ich lese hier ja schon eine ganze Zeit mit und habe dank deiner Empfehlung Abschied vom Windows Media Center genommen und schaue seitdem TV über XBMC MediaPortal-Frontend. Um Windows komme ich dank umfangreicher BD-Sammlung leider nicht herum.

    Wie sind die Umschaltzeiten bei PVR-Addons unter Linux? Unter Windows ist es wirklich ätzend, 3-5 Sekunden (per DVB-C) und trotz MP-TSReader und SSD. Würde mich mal interessieren…

    Danke & Gruß,
    Cedric

    1. Hi Cedric, das freut mich.

      Bei meinem Kollegen (TV-Karte: TeVii S470, TV-Headend: HTS) sind die Umschaltzeiten 1-2 Sekunden – also recht schnell.

      Wo liegt eigentlich das Problem bei der Blu-ray Wiedergabe unter Linux?

      Gruß Nico

      1. Hi Nico,

        Problem ist wohl der Kopierschutz (wie immer eigentlich). libbluray spielt nur unverschlüsselte Streams ab und kann auch keine Menüs… Es gibt wohl einne Hack über XBMC-Plugin mittels makemkv-Beta aber elegant ist das nicht und die DVD muss quasi erst „Vorentschlüsselt“ werden und wird dann mittels makemkv über HTTP an XBMC gestreamt.

        VG,
        Cedric

      2. Kleines Update bzgl. meines Umschaltproblems: Ich bin nun vom MediaPortal TVServer (Standalone) auf den 4TheRecord TVServer umgestiegen und siehe da: Umschaltzeiten wieder im normalen Bereich und auch kein Problem mehr mit Signalabbrüchen. Ich kann also jedem, der XBMC mit PVR unter Windows betreibt, empfehlen sich einmal 4TheRecord anzugucken!

  6. Ich habe auch eine Tevii S470 und hatte genau das gleiche Problem.
    Hab immer nur einen „normalen“ reboot gemacht und das hat nichts genützt.
    Durch ein richtiges herunterfahren und anschließendes Starten geht wieder alles.
    Ob das Problem durch ein Update kam? Es trat fast zeitgleich wie bei dir auf!
    Vielen Dank für den Tipp!

  7. Bei mir hilft ein kaltstart leider nicht. Ich bekomme meine TeviiS470 und XBMC nur unter openelec zum laufen, alle anderen derivate funktionieren nicht… 🙁

  8. Hey,

    euren Fehler kann ich sehr gut nachvollziehen.
    Habe folgendes System

    Intel H77 Board
    i5 Ivy Cpu
    Nvidia 210 Graka
    und ne Tevii 471 Karte

    Betriebssystem Ubuntu 12.04 mit 3.5er Kernel. Sprich für die 471 Tv Karte benötige ich lediglich die Firmware. Der Rest ist im Kernel.

    Wenn ich einen Kaltstart mache, funktioniert die Live TV mit XBMC 12.2, VDR 2.02 und XVDR Plugin.

    Nach Bereitschaft bekomme ich kein Bild mehr. Nur Neustart behebt das Problem. Komme leider selbst nicht weiter. Jemand schon eine Lösung gefunden.

    Neustart VDR bring auch nichts.

    Gruß

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.